Help please ? loadpackage error undefined procedure

I’ve run into a problem on which I’d appreciate advice.
I’m using swi-8.1.19 on Windows 10. I retrie with a fresh install. I’ve run into the same problem with 8.0.3.
I tried to load a simple program that uses the chr, library which produced errors. starting with
ERROR: Undefined procedure: loadpackage/1 (DWIM could not correct goal)

I tried installing the simple ‘hello’ package using install_pack and loading that from the console ,with the same result.

I can consult files fine, and run queries with no apparent problems.

So I’m puzled as to what is happening or how to proceed. Given the same response in multiple versions and the size of the user base I don’t suspect a bug. Any ideas as to what I might have done wrong or on how to proceed would be welcomed. I’ve only tried it on windows.


Mea culpa, I somehow confused
use_module with an imagined ‘loadpackage’

There is no fault in the implementation.
Apologies for any angst.

– David