Smileys


#1

Regarding Discourse.
Typing some code, I type ‘pred, colon minus enter’. See the effect of the smiley system here:

 pred :-1:
      true.

Can all the :- smileys possibly be disabled?


#2

As far as I can tell, we can only have emoji globally disabled or not. We can disable the “shortcut” emojis, but typed-out ones like :-1: will show up.
On the upside, I believe that emoji in code blocks (like above) don’t actually show up, just the annoying autocomplete while composing.

I will try to look in to settings to make this less annoying for writing code though – I know I constantly accidentally get :-1: in my code when trying to write :-


#3

So far, my preferred workflow with this beast is to follow discussions on email and react on the forum where you can properly format the text. If the answer is longer, write it in an editor as Markdown and paste it into the forum. As long as you do proper Markdown for code that seems to work fine.


#4

8cD 8cD 8cD 8cD 8cD 8cD 8cD 8cD

complete sentence needed by discourse, annie will go turn off more nanny checks later.