Emacs prolog-mode indentation of comments

I’m using prolog.el as recommended by https://www.swi-prolog.org/FAQ/GnuEmacs.html

One annoyance is that when a line starts with a single “%” and I hit “tab” (which is bound to indent-for-tab-command), it indents 32 spaces. I can turn this off by using a double “%%”. (This seems to be related to the behavior for same-line comments, which align at column 32.)
I’ve looked at the prolog.el code but can’t figure out how to change this behavior. Suggestions?

I’m using a slightly hacked-up version of prolog.el (here) but I don’t seem to be experiencing that indent issue…I have made modifications, but just to the indentation for 0'c constructs and dictionaries. Is it possible there’s some other Emacs setting governing that?

Your version is based on prolog.el-1.23 (the current version is 1.27) … and it doesn’t exhibit the indent problem. So, I can try finding older versions of prolog.el and identify where things changed. Thanks!