Status of Triple20 & ClioPatria


I would like to know what the status of Triple20 and ClioPatria is. Is there an attempt that they still work with the newest environment and SWI-Prolog version?

I have installed SWI-Prolog 8.2.4 on Windows 10, and installed ClioPatria and Triple20 from GitHub. ClioPatria seems to work in general, but the context graph is broken. I use Graphviz 8.0.3 (the latest), and all I can see in my browser is emptiness where the graph should be. (The environment variable for Graphviz is set. ClioPatria had complained about that, but I have already fixed that.) I’ve tried out the following browsers: Chrome, Firefox, Edge, and both the SVG and canviz settings. Would it help to install an earlier Graphviz version, and which one?

Triple20 doesn’t start at all. When I run, I get the following lines:

Warning: c:/git/triple20/src/ Deprecated … <newline>*. Use \c
ERROR: c:/git/triple20/src/ Syntax error: Operator expected
ERROR: c:/git/triple20/src/ Syntax error: Operator expected
ERROR: c:/git/triple20/src/ Syntax error: Operator expected
ERROR: c:/git/triple20/src/ Syntax error: Operator expected
Warning: c:/git/triple20/src/
Warning: Goal (directive) failed: user:(win_setup,true)

It also opens a window which is empty. I faintly remember that I could run Triple20 in an earlier SWI-Prolog version. But I might be wrong.

As it seems, neither Triple20 nor ClioPatria have been updated for a long time. Can I consider both applications as not (proper) usable at the moment?

Triple20 should probably be considered outdated. On the other hand it is most likely quite trivial to get it working again.

ClioPatria is sleeping, but I do intend to fix bugs and, who knows, to revive it when the opportunity arrives. I think the bug with rendering the context graph is related to a similar problem we had in SWISH: current graphviz produces invalid SVG :frowning: On it still works (graphviz version 2.40.1 (20161225.0304)). In SWISH we hacked around it by making the Prolog server read the SVG using the XML parser in a permissive mode and then have Prolog write the XML again :frowning:

For both, I’m happy to deal with PRs.

Thank you very much for your response.

Meanwhile, I’ve updated to SWI-Prolog 9.0.4. Now ClioPatria seems to be broken even more severely.

When I click on any locally loaded graph, I get the following:

Internal server error
select_dict/3: Duplicate key: file_errors

I’ve also de- and reinstalled ClioPatria, to no avail.

It’s already a benefit to know for sure that Triple20 and ClioPatria are not properly working at the moment. No wonder with all the updating rubbish of operating systems, browsers and so on.

Unfortunately I am no professional coder, so that I could help you with that.

Thank you once again.

I can’t reproduce this. Where did you get ClioPatria from (which exact version) and what exactly do you do?

Suggests and old version. My git origin is at GitHub - JanWielemaker/triple20: XPCE/SWI-Prolog based RDF browser and editor. It doesn’t give those. Didn’t work completely due to a change in getting the commandline arguments. Pushed a fix. That also adds support for .nt (N-Triples) files and fixes an issue in loading .ttl files. At least the basics seem to work fine.

What I did,

regarding ClioPatria: I got ClioPatria from here: I installed it via GitHub: git clone I also did the following, according to the above webpage: git submodule update --init web/yasqe, git submodule update --init web/yasr. Then I started win-config.exe and chose a folder for my ClioPatria sessions. I started SWI-Prolog and ran the created from that folder. I entered the predicate cp_server. I opened the Chrome browser and went to http://localhost:3020/. There I created (at first startup) an administrator account. When I go to “Repository/Load local file” or “Repository/Load from library”, upload some ontology, go to “Places/Graphs” and click on one of the listed graphs, the Internal server error occurs.

I deinstalled SWI-Prolog 9.0.4 and installed version 8.2.4, did the same procedure of starting the server (to be on the safe side, I first emptied my ClioPatria sessions folder and started win-config.exe once again), and everything is fine concerning that matter. (As already mentioned, the context graph is not working.)

regarding Triple20: I got Triple20 from here: I installed it via GitHub: git clone I started setup.bat. The mentioned lines and the empty window occur (no matter with which of the two SWI-Prolog versions).

Both were Windows specific problems. Pushed fixes.

For me the context graph works. Note that ordinary instances do not show a context graph. You should see one for e.g. classes that have subs and supers. ClioPatria doesn’t suffer from the same problems as Triple20 because it already reads, rewrites and writes the SVG.

The Internal server error is gone in SWI-Prolog 9.0.4. Thank you.

The context graph still doesn’t show up for me. I have also tested it with a sample ontology I created in Protege, Bookstore.owl, which has super classes and subclasses.

Here is a version of the Protege Pizza Tutorial, with super classes and subclasses, with the same issue: Do you know a common counter-example?

Triple20 still doesn’t start. I can run setup.bat, register Triple20 and create the shortcut. But when I click on the shortcut SWI-Prolog shows me the usage and the options of swipl-win.exe, with “Exit status is 1”, instead of starting Triple20.

Are you sure that the parameters in the target of the shortcut are correct (“C:\Program Files\swipl\bin\swipl-win.exe” -s “c:/git/triple20/src/” -L16m -G32m -T32m -g triple20)? I can’t find the -L, -G and -T parameters among the shown options.

There is probably something wrong running graphviz. Works fine on Linux with the pizza ontology. I only have a very basic Windows installation and rather wish to keep it that way. So, it is for you or some other Windows user to sort out …

These are flags for old versions. Should be removed. I don’t seem to be able to start Triple20 on Windows though. It should work to load into Prolog and run ?- triple20., but the system just stops. Works on Linux …

You can probably run the whole thing using WSL on Windows. Else someone has to debug the Windows version :frowning: Sorry.

I have the same behaviour.

I’ll try out ClioPatria and Triple20 once I have time to turn to Linux again. Till then your Semantic Web Library is big enough to keep busy for a while. I’ll stick to that for the intended chapter in my dissertation.

Thank you for your efforts.

Success! Note that if you want performance evaluation, the Linux version is significantly faster than the Windows version for many tasks on the same hardware. In part that is due to emulation. Quality of, notably, the C runtime library is probably another cause. That is for Linux on bare metal on the same hardware. Not sure how it compares through e.g. WSL.