SWISH Notebooks: problems updating/not-sharing when logged in


I’m new in SWISH and I’m trying to create a private SWISH notebook once I’m logged in (via google e-mail), so I do the following:

  • I log in (with the “Login with Google” button).
  • I select “Create Notebook” and write something.
  • I select “File/Save” and then choose a name and check only the “only me” box (I leave unchecked the remaining boxes, in particular the “public” one).

My notebook is saved, but then I find the following problems:

  1. I cannot modify my notebook unless giving it a new name even if I’m logged in: I update my notebook and when I try to save it I get the message “Permission denied. Please try a different name”.

  2. My file doesn’t seem to be private: if I open SWISH with another browser, without logging in, and search for notebooks, the file I created before appears on the list.

Thanks a lot in advance for your help !!


Sadly, all I can add here is a “me too”. I posted a similar question to

I find this is an intermitent problem. Sometimes I start a new notebook and saving updates works fine, othertimes I get the Permission denied. Please try a different name blues.

I also use my Google account to log in, so not sure if that’s related.

Thanks for your answer. You are right, indeed it seems to be an intermitent problem: I tried again and now it works … Regarding log in, I am neither sure it is relevant, but I mentioned it because I first tried without being logged in, and in that case all seemed to work fine (maybe just by chance?)

1 Like

I pushed two fixes. First of all a bug in forwarding the identity for oauth2 (Google, etc) identified users caused saving for only me to fail. It only worked for users with a local account (not available on the public instance). Second, the visibility rules have changed a little. You can (of course) always see your own files, but if users are not logged in your own is defined very loosely, eventually accepting the same IP. That is still the case, but if the file is supposed to be private it now demands the user is logged on so we can really identify the proper person.

Fixes pushed to the repo and the public swish instance is updated. Please test.


Works fine now.

Yes, now it seems ok. Thanks!!