Two issues with Emacs and PLDoc


I go back and forth from SWI to Emacs (either Aquamacs, or Emacs on Windows and Linux) to do editing and interacting with the listener.

I have two unrelated issues to raise.

  1. The Prolog inferior process in Emacs “eats up” the prompt, in the sense that it does not show it anymore; this happened with the upgrade to 8.x.

  2. Is there a way to disable PLDoc when consulting/compiling a file? Comments are comments and the PLDoc feature should not interfere with these operations; in 8.x it does.

Any ideas/suggestions about how to deal with them?