XPCE debugger problems

Hello,
I use Swi-prolog 8.2.1 on Ubutu 20.04

When I set the debugger options (Tools ->settings), for instance “Show unbound” set to True then Apply,
the setting come back to the default setting as soon as I use the right arrow -> to see the next line of the program.
Ti seems the user’s settings are not stored.

A second problem is that the debugger does not point the correct line code.
The only way I found to solve it, is to edit any prolog progam (during the run of the program I want to debug), and clik on “Browse” then “Prolog navigator”, after call the xpce debugger, that points the good line :

edit(my_program),
sleep(5)
gtrace,

Any idea for these two problems ?

(apart this, the graphical debugger is very useful)

Thanks a lot
Dominique