What does lib:Schema do in the RDF manifest file?

I am playing around with using the manifest file to load RDF schema and triples, but seem to be running into issues loading schema files. I took the example from here and tried to load it.

I copied the above file as Manifest.ttl in a temporary directory ‘/tmp/x’ and attached it via a dummy prolog script (and yes, none of the rdfs file being referred to in the manifest exist in the directory):

:- use_module(library(semweb/rdf11)).
:- use_module(library(semweb/rdfs)).
:- use_module(library(semweb/rdf_library)).

:- rdf_attach_library('.').

Ran the script and as expected I get the missing file errors when I do the actual library load. Here is the error:

?- rdf_load_library('wn20-basic', []).
Correct to: "rdf_library:rdf_load_library('wn20-basic',[])"? yes
ERROR: urls `['file:///tmp/x/wordnet-attribute.rdf.gz','file:///tmp/x/wordnet-causes.rdf.gz','file:///tmp    /x/wordnet-classifiedby.rdf.gz','file:///tmp/x/wordnet-entailment.rdf.gz','file:///tmp/x/wordnet-glossary.rdf.gz','file:///tmp/x/wordnet-hyponym.rdf.gz','file:///tmp/x/wordnet-membermeronym.rdf.gz','file:///tmp/x/wordnet-partmeronym.rdf.gz','file:///tmp/x/wordnet-sameverbgroupas.rdf.gz','file:///tmp/x/wordnet-senselabels.rdf.gz','file:///tmp/x/wordnet-similarity.rdf.gz','file:///tmp/x/wordnet-substancemeronym.rdf.gz','file:///tmp/x/wordnet-synset.rdf.gz','file:///tmp/x/wnSkosInScheme.ttl.gz','file:///tmp/x/wnskosmap','file:///tmp/x/wnskosmap.rdfs','file:///tmp/x/wnbasic.rdfs']' does not exist

The definition of wnskosmap in the example is:

        a lib:Schema ;
        lib:source wn20s: ;
            <wnskosmap.rdfs> .

So file:///tmp/x/wnskosmap.rdfs being missing makes sense. What I don’t get is the name file:///tmp/x/wnskosmap in the list. Why is it looking for that? That is the only one tagged as lib:Schema and hence the question.

Its long ago. Possibly the fact that the target file is missing causes it to ignore the void:dataDump and thus consider this a description of a file rather than a virtual resource. Please try first with all data files in place.

Thanks for getting back to me. I did try that by doing the following (just created an empty file):

touch wnskosmap.rdfs

And still get file:///tmp/x/wnskosmap in the missing file list, but file:///tmp/x/wnskosmap.rdfs is not longer in the missing list (so it does find that).

However, if I change lib:Schema to void:Dataset in the manifest file, file (file:///tmp/x/wnskosmap) is no longer considered missing (with or without having the empty wnskosmap.rdfs file in the directory).

Is this package not considered supported anymore? That is perfectly fine. It is really not that hard just to load the file individually, but I really like the idea of the manifest file and was experimenting with it.

Its not used much (I think). It is also ended a bit “in between”. I emerged before the _void _ vocabulary, then was updated to use void, but as void still was lacking stuff we need it is now a bit of a mess. It won’t disappear and I’m happy to handle pull requests for the docs or the implementation.