How to set font size on graphical debugger?

I can I increase the sizes of everything in the graphical debugger? I need a magnifying glass to read it.

Background: I’m trying to debug a server, and the only way seems to be tspy/1, which brings up the graphical debugger. Normally, I use the old&trusty debugger under emacs, or add print statements to my code.

Alternatively: is there a way to run http_server in non-threaded mode so that spy/1 and friends work? (Yes, I know that this causes other problems when there are multiple requests to the server.)

The font.scale variable in the “Editor preferences” is also used for the debugger. You can edit it in PceEmacs, just start it:

?- emacs.

and then go to “Edit” --> “Editor preferences”.

I don’t know how to “reload” the settings. I had to “halt” and then start the interactive interpreter again for the changes to take effect.

1 Like

Yes, editing ~/.config/swi-prolog/xpce/Defaults font.scale did the trick (almost). I had to remove the leading ! (having forgotten the conventions for X11 config files).

I’ll have to do some more fiddling to get the debugger help displaying at a size I like.

@jan - if the debugger help is available in the SWI-Prolog online documentation, I couldn’t find it and “grep” only found me xpce/prolog/lib/trace/pltracer.hlp.