Solved. XPCE Tools no longer work after upgrading os OSX Ventura

Earlier today I was using all of the XPCE tools. After an update to OSX Ventura, they no longer work. There is no error, just true., XQuartz loads, and then nothing.
I’ve re-installed/updated xcode, and apple’s command line tools, and re-installed swi-prolog 9.1.8.

I just noticed and tried the “check installation” feature. It complains that Loading library(jpl) failed. But it seems this is ok. It also complains “Could not find SWI-Prolog on $PATH”. It’s set up fine in my shell. Anyway, no complaints about anything else.

Works fine for me (Ventura 13.3.1 on M1). XQuartz That is XQuartz from Macports AFAIK. There was some issue with the binary for the M1, mostly being really slow if I recall correctly.

XQuartz full-screen mode was the problem.

In more detail:
I updated to Ventura to attempt to resolve XQuartz issues not related to SWI-Prolog.
In my troubleshooting prior to update, I played with some XQuartz settings, one of them being the “full-screen mode” toggle.
In this state, the SWI-Prolog console renders full screen, but all other SWI-Prolog windows exist in some inaccessible view (hence no errors). This appears to be an XQuartz issue, because the built-in XQuartz Terminal has the same problem.